PDA

View Full Version : Power Gear leveling Jacks


Arthur Hayes
09-02-2007, 11:39 PM
Suddenly my leveling jack panel has started causing me fits. I was all set to leave my site and when I turned on the jacks at the control panel all I got was flashing lights. The manual says this is due to low voltage. Tested the circuits at the panel and all were above minimum. Only way I could go was to release the parking break and let the safety system retract them. The light flashed all day. The next day I removed the panel from the dash and cleaned all the contacts. Thought I had it cured until I started to replace the screws, the light started flashing again. Removed panel from dash and they would stop, and system would work, but as soon as I put it back on the dash the problem would raise its ugly head. Maybe the printed circuit is bad, don't know. Has any one encountered this in the past?

jdavis
09-14-2007, 12:23 PM
My husband and I had this happen last weekend in our 2008 Tourmaster. Call Power Gear, have your model number. They got us all fixed up and running again!

Arthur Hayes
09-15-2007, 12:04 AM
Thanks for the reply, I did just that through Gulf Stream and I have an appointment for this Monday for the Jacks and other things.

Arthur Hayes
09-29-2007, 11:28 AM
Took the unit into Aloha RV in Albuquerque and had their tech call Power Gear. They did some test and it was determined that the control module was the problem. Power Gear sent a new one, (no charge) I plugged it in and everything worked. In fact it worked better that the original, the original would sometimes shut itself off when I was extending the rear jacks. The new one just keeps on going.