View Full Version : First trip in new RV

11-22-2007, 01:42 PM
I took delivery of my Tour Master T40F about a month and a half ago. Due to the crazy work schedule, I had been unable to take the rig out for an extended trip. Until the other day, the longest ride was the one from the dealer in Jacksonville back to our house in South Florida. At the end of the 300 + mile trip, the RV's check engine light was on.

Yesterday, we pulled the RV out of storage to hit the highway along with the throng of other holiday travellers. When we arrived at the storage lot, we were surprised to find that the electic jacks would not retract. The folks at Power Gear were great to walk us through the trouble-shooting and to e-mail us a copy of the correct users' manual for the Power Gear electronic levelling device.

When we drove off in the RV, the check engine light went off and remained off for quite some time. During our 700 mile ride yesterday, the check engine light came on for about 10 minutes and then went back off. As things stand, the check engine light has not come back on.....and I'm surprised why it ever came on to begin with.

Last night, when we stopped for a bite to eat at Whataburger (you can't get those in South Florida), I was surprised to find that I had no power steering. Getting back on to the interstate was a challenge, to say the least. Later on that evening when we arrived at our destination, the power steering was working once again???? I had checked the resevoir when we first had problems and it was sufficiently supplied with fluid. There were also no evident signs of leaks. This one is puzzling me.

Have any of you had similar issues with intermittant problems such as what I've encountered with the check engine light and the power steering? I like the RV and I'm looking forward to getting the bugs worked out. I'm just wondering what bug will come next and how long it will linger.

Best regards,

11-22-2007, 08:11 PM
Mike, we've had none of those problems on our TM. However, other issues, yes. Charlie

11-22-2007, 09:18 PM
What year of TM?

Check engine: we had our TM only about a month when our check engine light came on. It come on at idle, go out at road speed, ie, I was going to have it looked at and the light went out.
The shop checked the air-filter, and it was plugged. They could not clean it as it is a canister, so $200 to replace it later I've not had any check engine lights since.

Steering is much more serious. I've heard that Freightliner has a "voluntary" recall on certain chassis as the power-steering fluid filter is back at the radiator, and the power-steering unit is 40 feet ahead at the front. The filter may cause fluid not to pump to the power unit at the front wheels.

A trip to the dealer is in order. Check with Freightliner with your serial # to see if yours is one of the models in need of power-steering revision.
Safe travels

11-23-2007, 12:46 PM
Thanks Rick and Charlie for your input. We'll get a visit to the dealer scheduled in short order. I think that we're absolutely going to love the T40F. Once again, it's just a matter of getting the bugs worked out.

Rick, the RV is brand new with just over 2,000 miles as a result of our holiday trip (about 1,200 of those miles were associated with the RV being delivered to the dealer). I believe that the model year on the chasis is technically '07. I remember that we had an issue with the insurance company due to the fact that the paperwork from the dealer showed one year and the VIN was tied to the chassis which was actually another year. I believe it's an '08 model built on an '07 chassis. I'm thinking that the T40 with the full body slide out is a brand new model. Long story short, it's a brand new model, complete with a few issues that need to be sorted through. We're going to take some shorter trips to get used to the rig and to get the issues identified and fixed. Hopefully, this summer we'll head out with the kids and do the "great American RV trip," complete with the Grand Canyon, Grand Tetons, Yellowstone, PCH, etc.

Best regards,

11-23-2007, 07:02 PM
If it is a Gulf Stream 2008 model, make sure your Florida title shows 2008 and not 2007.

I bought a 2006 GS Ultra built on a 2005 Chevy chassis. Florida sent me a title saying it was a 2005 vehicle. When I questioned them on it, they admitted their error. I sent the title back to them and they reissued it as a 2006 vehicle.

11-23-2007, 08:20 PM
Thanks MFA,
Will do.

Best regards,

11-23-2007, 11:51 PM
You can call Frieghtliner with your S/N and they will tell you if your unit is one of the units that needs work on the power steering. I called them about my unit. I got a machine which just ticked me off however to my surprise they called me back in short order and took care of me. Nice people to deal with.

11-24-2007, 12:20 AM
who did you buy it from in Jacksonville?

11-25-2007, 07:40 PM
I'll check with Freightliner tomorrow.

I picked up the RV in Jax from Dick Gore's RV World. They cut a pretty good deal and seemed like good folks to deal with. It's quite a haul, however, to go there for service so I'll have to find somebody a little closer to S. Florida.

Best regards,