PDA

View Full Version : New (to us) 2005 BT Cruiser/ Slide-Outs Not Working!


daveandval
10-30-2015, 05:04 PM
Brought her home two days ago. The slide-outs wont slide out (they were out when we looked at her prior to purchase). The battery is fully charged. Have tried everything we can think of. Have checked all fuses. We did not get a manual. Would sincerely appreciate any suggestions. Where can we get a wiring diagram? Thank you in advance!

LabCab
10-30-2015, 09:55 PM
You may want to try "running" the engine and operating the slides. That is how they work in a Super Nova. Try it.

slaredo
01-29-2016, 11:13 PM
I see this is a few months old, but I wanted to note that on my 2005 BT Cruiser the parking brake must be on to put out the slides.

LabCab
01-30-2016, 01:02 PM
See that, ya learn something new about these GS's every day. :lol:

bfrazier
07-08-2017, 03:47 PM
I see this is a few months old, but I wanted to note that on my 2005 BT Cruiser the parking brake must be on to put out the slides.

I see this is your only post. Your only post here was made in order to be helpful to another user. That makes you awesome in my book. I have an '06 BT Cruiser, slides are working, knock on wood.

THenne1713
08-05-2017, 11:14 PM
(On some slides) the DRIVER'S SEAT must be fully forward, and has a seat position switch to prevent slide from damaging seat

bfrazier
08-06-2017, 09:59 AM
(On some slides) the DRIVER'S SEAT must be fully forward, and has a seat position switch to prevent slide from damaging seat

Hey, I see you just joined. Do you have a BT Cruiser? (Sounds like it!) Which model? I about flipped the first time my slides wouldn't work... until I set the e-brake. Derp.

Bob

THenne1713
08-08-2017, 02:12 AM
(New to me) 99 Conquest Limited e450, about 3-weeks now, cleaning, polishing, studying, learning... (wish mine had the drivers seat switch option :-)... Long sucker, low ground clearance on the tail :-) , a few stories on inspection finds so far :-)

FredF
09-07-2017, 06:15 AM
Same thing happened to me. Picked it up new on Friday afternoon. By the time I got home the dealer was closed and the slides didn't open. I wasn't impressed. If all else fails, read the manual. It said driver's seat forward and parking brake on. When I follow the instructions it works like a charm. Still forgot several times on the first trip out.

bfrazier
09-07-2017, 09:45 AM
Same thing happened to me. Picked it up new on Friday afternoon. By the time I got home the dealer was closed and the slides didn't open. I wasn't impressed. If all else fails, read the manual. It said driver's seat forward and parking brake on. When I follow the instructions it works like a charm. Still forgot several times on the first trip out.

It's fun to laugh at ourselves I guess! I will continue to forget, I'm sure.

THenne1713
09-20-2017, 03:08 AM
Can you put a test light/ meter across the IN/ OUT switch to see if it is getting power, or is itself bad? LET US KNOW WHAT YOU FIND???

THenne1713
09-20-2017, 03:10 AM
Whoops, just noticed his post is 2-yrs old... :-)