Gulf Stream Owners RV Forum
 


Notices

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-12-2016, 03:37 PM   #1
DaveS
Junior Member
 
Join Date: May 2016
Posts: 1
Default 12 volt electrical problems in 2016 Gulstream Conquest

Hoping somebody can give me some guidance on this.

I went camping a few weeks ago with the unit and when I got home I noticed the 12 volt power to the unit was dead. nothing worked. it was like the battery was not attached. I put a meter to the battery and it was 12 something (I forget the exact number now). the only way I was able to get the 12 volt power to work again was to plug into an outlet in my driveway. I let it sit like that for a while, unplugged and everything seemed to work. Recently I had the camper plugged in for 3 days to charge it for a trip this weekend. When I unplugged it and went inside to test the 12 volt system 1. the battery only showed 2 of 4 lights so it isn't charging and 2. when I flipped the switch for the water pump the whole system died again. So now i'm going to try and plug it back in and see if that fixes it again. Anybody ever see anything like this??

Dave.

Edit:
I put a meter to the battery and I reads 13.01 so battery is charging, but only reads 2 of 4 bars on panel.

I also just plugged into driveway outlet. 12 volt system now works again. When I unplug from outlet, 12 volt system works again as normal. WTH!!
DaveS is offline   Reply With Quote
Old 05-31-2017, 02:12 PM   #2
big john
New Member
 
Join Date: May 2017
Posts: 5
Default Re: 12 volt electrical problems in 2016 Gulstream Conquest

We're you able to find your issue? I have a 2016 241RB Ameri-Lite and have the exact same issue. I've had the unit to the dealer several times and it's always we can't find a problem. My latest thought is that the ground wire off the battery was not properly grounded ao I have replaced the cable and made sure the ground was good. Now only time will tell. I'd appreciate any thoughts you might have.
big john is offline   Reply With Quote
Old 06-12-2017, 10:26 PM   #3
Dgears02
New Member
 
Join Date: Jun 2017
Posts: 11
Default Re: 12 volt electrical problems in 2016 Gulstream Conquest

That is a weird issue. Good suggestion on checking the cables, especially the ground for any loose contact.
Dgears02 is offline   Reply With Quote
Old 03-02-2019, 09:28 PM   #4
Elkbow2003
New Member
 
Join Date: Mar 2019
Posts: 2
Default

I just purchased a used 2018 Gulf Stream Conquest 30'. Only the slide out would operate off of battery power. None of the inside lights, etc worked. I did find the 25 amp fuse near the battery was blown, but replacing it did not help with the issue.
I then plugged the unit into A/C power, everything seems to work fine. I will try to trace the problem, just hoping someone here might point me into the right direction.
Elkbow2003 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2016 Conquest C 6237 wbraunberger Hall of Fame 0 10-24-2016 02:41 PM
Electrical problems 03heritagerider Class A 16 05-04-2014 12:04 PM
Electrical problems on Yellowstone 34FBR djbcs 5th Wheels 4 10-11-2009 08:31 AM
12v electrical problems Jobuha Electrical 11 11-13-2007 08:47 PM
Electrical Issue - Conquest 6331 Super C afetherolf Class C 3 08-18-2006 07:30 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:18 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.