Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-30-2015, 04:04 PM   #1
daveandval
Junior Member
 
Join Date: Oct 2015
Posts: 1
Default New (to us) 2005 BT Cruiser/ Slide-Outs Not Working!

Brought her home two days ago. The slide-outs wont slide out (they were out when we looked at her prior to purchase). The battery is fully charged. Have tried everything we can think of. Have checked all fuses. We did not get a manual. Would sincerely appreciate any suggestions. Where can we get a wiring diagram? Thank you in advance!
daveandval is offline   Reply With Quote
Old 10-30-2015, 08:55 PM   #2
LabCab
Senior Member
 
Join Date: Oct 2009
Posts: 119
Default Re: New (to us) 2005 BT Cruiser/ Slide-Outs Not Working!

You may want to try "running" the engine and operating the slides. That is how they work in a Super Nova. Try it.
__________________
Great Wife, 3 fine Labradors and a '08 Supernova ready to roam!
LabCab is offline   Reply With Quote
Old 01-29-2016, 10:13 PM   #3
slaredo
Junior Member
 
Join Date: Jan 2016
Posts: 1
Default Re: New (to us) 2005 BT Cruiser/ Slide-Outs Not Working!

I see this is a few months old, but I wanted to note that on my 2005 BT Cruiser the parking brake must be on to put out the slides.
slaredo is offline   Reply With Quote
Old 01-30-2016, 12:02 PM   #4
LabCab
Senior Member
 
Join Date: Oct 2009
Posts: 119
Default Re: New (to us) 2005 BT Cruiser/ Slide-Outs Not Working!

See that, ya learn something new about these GS's every day.
__________________
Great Wife, 3 fine Labradors and a '08 Supernova ready to roam!
LabCab is offline   Reply With Quote
Old 07-08-2017, 02:47 PM   #5
bfrazier
New Member
 
bfrazier's Avatar
 
Join Date: Jun 2017
Posts: 20
Default

Quote:
Originally Posted by slaredo View Post
I see this is a few months old, but I wanted to note that on my 2005 BT Cruiser the parking brake must be on to put out the slides.
I see this is your only post. Your only post here was made in order to be helpful to another user. That makes you awesome in my book. I have an '06 BT Cruiser, slides are working, knock on wood.
bfrazier is offline   Reply With Quote
Old 08-05-2017, 10:14 PM   #6
THenne1713
Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 39
Send a message via AIM to THenne1713 Send a message via MSN to THenne1713 Send a message via Yahoo to THenne1713
Default

(On some slides) the DRIVER'S SEAT must be fully forward, and has a seat position switch to prevent slide from damaging seat
THenne1713 is offline   Reply With Quote
Old 08-06-2017, 08:59 AM   #7
bfrazier
New Member
 
bfrazier's Avatar
 
Join Date: Jun 2017
Posts: 20
Default

Quote:
Originally Posted by THenne1713 View Post
(On some slides) the DRIVER'S SEAT must be fully forward, and has a seat position switch to prevent slide from damaging seat
Hey, I see you just joined. Do you have a BT Cruiser? (Sounds like it!) Which model? I about flipped the first time my slides wouldn't work... until I set the e-brake. Derp.

Bob
bfrazier is offline   Reply With Quote
Old 08-08-2017, 01:12 AM   #8
THenne1713
Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 39
Send a message via AIM to THenne1713 Send a message via MSN to THenne1713 Send a message via Yahoo to THenne1713
Default

(New to me) 99 Conquest Limited e450, about 3-weeks now, cleaning, polishing, studying, learning... (wish mine had the drivers seat switch option ... Long sucker, low ground clearance on the tail , a few stories on inspection finds so far
THenne1713 is offline   Reply With Quote
Old 09-07-2017, 05:15 AM   #9
FredF
New Member
 
Join Date: Sep 2017
Posts: 2
Default

Same thing happened to me. Picked it up new on Friday afternoon. By the time I got home the dealer was closed and the slides didn't open. I wasn't impressed. If all else fails, read the manual. It said driver's seat forward and parking brake on. When I follow the instructions it works like a charm. Still forgot several times on the first trip out.
FredF is offline   Reply With Quote
Old 09-07-2017, 08:45 AM   #10
bfrazier
New Member
 
bfrazier's Avatar
 
Join Date: Jun 2017
Posts: 20
Default

Quote:
Originally Posted by FredF View Post
Same thing happened to me. Picked it up new on Friday afternoon. By the time I got home the dealer was closed and the slides didn't open. I wasn't impressed. If all else fails, read the manual. It said driver's seat forward and parking brake on. When I follow the instructions it works like a charm. Still forgot several times on the first trip out.
It's fun to laugh at ourselves I guess! I will continue to forget, I'm sure.
bfrazier is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
slide outs 3454terryg Class A 10 05-11-2013 12:04 PM
2005 GS ameri-lite 24 foot w rear slide out not working Rich in Red bank Travel Trailers 1 07-31-2012 07:15 PM
Slide outs don't work jhiggy Class C 6 06-19-2011 07:56 AM
2005 BT Cruiser-Slide Out Problems happyhattie Class C 1 09-02-2007 09:37 AM
leaks around the slide outs darlene tarleton Class C 2 07-11-2007 09:38 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:19 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.