Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-12-2018, 09:38 AM   #21
Restorium
Senior Member
 
Restorium's Avatar
 
Join Date: Apr 2018
Posts: 108
Default

Sudsy,
You are definitely the judge of how you feel about my posts. So I will apologize for making you feel bullied. Didn't intend on that. Sorry.
__________________
1999 Sunsport with Ford Chassis
Restorium is offline   Reply With Quote
Old 08-13-2018, 09:41 PM   #22
Kurlon
New Member
 
Join Date: Aug 2018
Posts: 8
Default

So, rig is a Ford chassis, not a Chevy. I haven't pulled a coil pack off yet but AFAIK there isn't a separate wire on these? On the same topic, it is eating oil as well so I'm thinking PCV valve(s) need replacing too. (Possibly the hoses as well.) Annoyingly none of the local parts shops had them of the shelf, or worse could find a PN?!

Had my first race weekend in the rig, absolutely love it. Only issue I ran into was the house battery being shot. Barely an hour with just the fridge on propane and the propane monitor and... reading as dead on the panel. So, ran the generator all weekend. (1/4 tank of gas). Checked tonight... batt was WAY low on water. Topped it off, guessing it's capacity is compromised anyways. Fortunately the next few outings I'll have access to shore power so I'm not going to worry about it at the moment.
Kurlon is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:02 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.