Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-13-2016, 08:53 PM   #1
bertnspike
Junior Member
 
Join Date: Apr 2016
Posts: 2
Default Transmission problems 2005 Independence

I have a 2005 Gulf Stream Independence with the Ford F-10 gas engine. Somehow a cable from the transmission fell down onto the exhaust and melted. Does anyone have any idea what I'm talking about? Until this happened I didn't even know transmissions had cables! Gulf Stream told my RV repair guy that the cable is obsolete and he can't get one. I find that ridiculous. There must be thousands of 11 year old trucks and RVs out on the road with the same engine. Wouldn't there be a few with the same transmission?

So... any ideas about this cable and where to get one?

I do not know how I drove this RV 42,000 miles over the last 5 years without this happening before. It happened when I moved about 1/4 mile to get a propane refill. When I came back to my site and backed in - all of a sudden I had no gears and had to shut it down to stop it.

Hoping for some hints.

Susan
bertnspike is offline   Reply With Quote
Old 04-14-2016, 12:48 AM   #2
RayChez1
Senior Member
 
Join Date: Jun 2005
Posts: 1,046
Default Re: Transmission problems 2005 Independence

How about a Ford repair facility? If it is a Ford chassis it seems to me like that would be the place to take it to. Even though I think that there are some parts that Ford will not carry anymore if it is over ten years old. I know because I have a Ford F-250 and I needed a part and they told me that they did not carry parts for a truck or car over ten years old, so I went to a salvage place and got the part used.

Not sure what cable you are talking about, but a good transmission mechanic should know exactly what to get and where to get it.
__________________
2002 Gulf Stream Scenic Cruiser
2018 Buick Envision Essence
Neway Freightliner chassis
Aventa II Blue Ox
RayChez1 is offline   Reply With Quote
Old 04-14-2016, 07:24 PM   #3
bertnspike
Junior Member
 
Join Date: Apr 2016
Posts: 2
Default Re: Transmission problems 2005 Independence

Thanks Ray. That's the first good answer I've received. Gulf Stream told me it was a gas chassis and not a diesel?!?! I never said it was a diesel! What dips they are. Otherwise they were useless. At least I know now what kind of fuel I should have been using over the last 5 years! hahahaha. I guess next I'll contact Ford and see what suggestions they offer, if any. I can't TAKE it anywhere... it won't run!
bertnspike is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil changes/transmission maintenance Bridgettmclaughlin Class A 3 12-20-2015 10:20 AM
Transmission problem joeblo Class A 1 07-10-2013 11:39 PM
Transmission question WE B RVN Class A 7 02-03-2008 10:18 AM
2005 BT Cruiser-Slide Out Problems happyhattie Class C 1 09-02-2007 09:37 AM
Purchase a New 2005 Independence? Snowbird 2 Class A 10 08-14-2006 04:30 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:34 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.