Gulf Stream Owners RV Forum
 


Notices

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-09-2019, 05:30 PM   #1
Kleber314
New Member
 
Join Date: Apr 2019
Posts: 2
Default Fresh Water Pump Operation

New Owner of a 2007 GS BT Cruiser. Have not used the fresh water system yet. Attempted today. Have followed the directions. Pump running but no water or air from faucets. Are there hidden switches or a trick to priming the pump? Do not want to take to dealer for something that we are missing.
Kleber314 is offline   Reply With Quote
Old 04-09-2019, 08:07 PM   #2
Leisure Time Larry
Member
 
Leisure Time Larry's Avatar
 
Join Date: Nov 2017
Posts: 38
Default

What model BT Cruiser?
Is the line from the fresh water tank hooked up to the pump?
Is there an inline strainer that could be clogged?
Is there enough water in the fresh water tank for the pump to pick it up?
Are the low point drains closed? (Is water being pumped out onto the ground?)
Both hot and cold? Is the hot water heater valve in Normal or Bypass? (If using hot, and valve is in normal, your pump will work to fill your WH before pushing water out to the faucets.)

That's what I have for now. That said, these pumps are kinda cheap, and they do go out. For $70, it would be worth replacing it if it is suspect with a newer 4 chamber model that won't pulse, over taking it to the dealer.

Good luck!

p.s. Pictures are worth a thousand words, and video is even better.
__________________
2005 22' BT Cruiser 5211, Chev. 6.0L; 2015 6'x12' EZ Loader Duralite Aluminum Cargo Trailer; 2015 Honda CB500X motorcycle for street and ADV riding; 2004 Yamaha TW200 motorcycle for dual-sport and trail riding...All of it for fun and adventure!
I live for this!...YouTube @https://www.youtube.com/LeisureTimeLarry & Instagram @https://www.instagram.com/leisuretimelarry
Leisure Time Larry is offline   Reply With Quote
Old 04-09-2019, 09:25 PM   #3
Kleber314
New Member
 
Join Date: Apr 2019
Posts: 2
Default

Technology!! Wrote out a detailed reply and the site logged me out without posting it. I have a 5291, 31'. I will look at everything tomorrow that you have suggested and post back.

Thank you for your help! Much appreciated.

Ted
Kleber314 is offline   Reply With Quote
Old 04-11-2019, 06:50 AM   #4
Restorium
Senior Member
 
Restorium's Avatar
 
Join Date: Apr 2018
Posts: 355
Default

I would go with what Larry said about the pump not hooked up.

When I winterize I unhook the pump and hook up an air line to push all the water out of the system. I hook it back up when I'm done, maybe the previous owner leaves it unhooked in the winter.
__________________
1999 Sunsport with Ford Chassis
Restorium is offline   Reply With Quote
Reply

Tags
water pump operation

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:19 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.