Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-13-2018, 01:20 PM   #1
Restorium
Member
 
Restorium's Avatar
 
Join Date: Apr 2018
Posts: 39
Default 1999 SunSport Fan Relay Location

I've been having a problem with my heater fan circuit for years. The fan work intermittently. Comes on, goes off, for no reason. I tested the fan and resister and they are fine. Sometimes I can turn the key on and off and it will work. Sometimes hit a bump and it will work. When it works it work flawlessly on all speeds. Power mirrors are on the same circuit because they come on and off with the fan.
Anyone else had this problem? I've been swapping out relays with no luck. I have no idea which relay is for what.
Thanks for any help.
Restorium is offline   Reply With Quote
Old 04-13-2018, 03:13 PM   #2
Restorium
Member
 
Restorium's Avatar
 
Join Date: Apr 2018
Posts: 39
Default

I replaced the ignition switch under the column. Also replaced all of the 5 pin Ford relays, the black ones, under the hood. Replaced the same kind of relays down in the panel near the driver's foot.
Restorium is offline   Reply With Quote
Old 04-18-2018, 08:33 AM   #3
Restorium
Member
 
Restorium's Avatar
 
Join Date: Apr 2018
Posts: 39
Default

Replaced the three white Ford relays under the hood. Still no luck.
The problem in this previous thread seems like it's identical to mine but I can't find the relay.
Previous relay thread link; http://www.irv2.com/forums/f258/dash...-189770-2.html
Restorium is offline   Reply With Quote
Old 04-24-2018, 10:19 AM   #4
Restorium
Member
 
Restorium's Avatar
 
Join Date: Apr 2018
Posts: 39
Default

Take her out of storage day.

Start her up and the fan and mirrors do not work. Drive 5 miles to the propane place. Start her back up to pull up to the front to pay and the fan and mirrors work perfectly.
Start her back up to leave and the fans and mirrors don't work. Drive her up to the gas station 2 miles away, still not working. Start her up to leave the gas station and still not working. Before I can make it out of the parking lot the fans and mirrors work again and function properly all the way home.
What is that? It's driving me nuts!
No ideas anyone?
Restorium is offline   Reply With Quote
Old 04-25-2018, 02:12 PM   #5
Sudsy
Senior Member
 
Sudsy's Avatar
 
Join Date: Mar 2017
Location: Mechanicsville, Md.
Posts: 132
Default Vacuum Leak?

Have you checked for a vacuum leak? Ford uses vacuum to control the heater and AC. I once had a heater control that had an internal leak.



Sudsy
__________________
2005 Sun Voyager Workhorse W24 with 8.1 ltr Chevy. Allison 2100 transmission. Full body paint.
Sudsy is offline   Reply With Quote
Old 04-26-2018, 05:49 AM   #6
Restorium
Member
 
Restorium's Avatar
 
Join Date: Apr 2018
Posts: 39
Default

Thanks Sudsy. On this Ford the switch uses vacuum to open and close the vents. That works fine all the time.
Restorium is offline   Reply With Quote
Old 05-02-2018, 09:01 AM   #7
Restorium
Member
 
Restorium's Avatar
 
Join Date: Apr 2018
Posts: 39
Default

Checked the fan ground and it has a good ground.
Restorium is offline   Reply With Quote
Old 05-02-2018, 05:34 PM   #8
Restorium
Member
 
Restorium's Avatar
 
Join Date: Apr 2018
Posts: 39
Default

Ah, victory at last. The problem was the relay in the center of the picture below. The picture is rotated, it needs to be 90 degrees clockwise to be a correct view. Hope this helps others that have intermittent dash power failure.
Attached Images
File Type: jpg IMG_0299.jpg (225.1 KB, 2 views)
Restorium is offline   Reply With Quote
Old 05-02-2018, 05:38 PM   #9
Sudsy
Senior Member
 
Sudsy's Avatar
 
Join Date: Mar 2017
Location: Mechanicsville, Md.
Posts: 132
Default Good for you

That's what determination can do! Congratulations.



Sudsy
__________________
2005 Sun Voyager Workhorse W24 with 8.1 ltr Chevy. Allison 2100 transmission. Full body paint.
Sudsy is offline   Reply With Quote
Old 05-03-2018, 07:31 AM   #10
Restorium
Member
 
Restorium's Avatar
 
Join Date: Apr 2018
Posts: 39
Default

Thanks Sudsy!
Just in time too. It's hot and the first trip of the year starts soon.
Restorium is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:11 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.