PDA

View Full Version : filling fresh water tank


Kramervskramer
11-14-2018, 09:48 PM
We have recently purchased a 2018 Bt cruiser. We have hooked up to city water successfully but are trying to figure out how to fill the water tank. There is an opening to fill the water tank by gravity feed, but when we put the hose in the opening, the water will not go into the storage tank. It runs back out of the filling pipe.

Sudsy
11-15-2018, 10:35 AM
We have recently purchased a 2018 Bt cruiser. We have hooked up to city water successfully but are trying to figure out how to fill the water tank. There is an opening to fill the water tank by gravity feed, but when we put the hose in the opening, the water will not go into the storage tank. It runs back out of the filling pipe.




Check your levels and make sure it isn't already full. If it's not full try reducing the water pressure of the hose you're using. There is a vent next to the fill hole in the gravity fill. Normally the water would flow into the tank and when it is full it comes back at you out of the smaller vent hole. When things are working normally you should feel/hear air coming from the vent hole.



If you do find the tank full and you didn't fill it I would drain it and flush with a little bleach and water then drain that and re-fill.


Sudsy

Restorium
11-15-2018, 10:44 AM
When filling make sure the unit is level. Not sure if it's like ours, if I had the MH leaning enough it probably would just come back out like you are describing.

jayme
11-23-2018, 06:41 PM
Check the screen on the vent from the tank. They sometimes plug up. On my BT I think the position of the filler is too low, causing water to leak out after filling. I too had a problem filling the tank. Solved by cutting an old hose long enough to reach the tank, and installing it to the filler hose.

Kramervskramer
11-25-2018, 08:49 AM
Thanks. Screen is not clogged so we will try the hose when we get a chance.

purduepete2
11-25-2018, 06:46 PM
I have a 2007 BT Cruiser 5291B
I had the same problem when it was new and took it back under the warranty and they reduced the length of the fill hose going to the tank and that solved the problem. The hose was so long that it would just push the water back out the fill connection. I still have problems with my shower drain. It's not vented properly and it doesn't drain freely. Should have had it addressed under warranty. Too late now!

Pete

Gulf Santa
11-25-2018, 09:03 PM
I have had similar problems. I've only been able to fill my tank very slowly by the gravity fill. I also can't seem to get my BT to work off city pressure. I hook up the hose but it seams my tank gets drained with use not using the city pressure. I've check the valves under the bed and whatever I try doesn't work. This is nothing like my class A Holiday Rambler. I'm going to follow this tread and maybe I'll learn something here.

jayme
11-26-2018, 12:50 AM
I hope once hooked up to city water, you turn your pump off? If not, you will be using both city and tank.