RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-02-2020, 01:01 PM   #1
williewho
New Member
 
Join Date: Oct 2020
Posts: 2
Default slider not working

Hi folks, i have a 2005 BT cruiser class C, my bedroom slider works great but for some reason my living/kitchen slider is no longer working, I press the button and nothing happens, the manual says check the circuit breaker but i have no idea where it is, the manual says its either in the front or rear exterior electrical panel.

any help is greatly appreciated.

Williewho
williewho is offline   Reply With Quote
Old 10-03-2020, 11:49 AM   #2
Draco
New Member
 
Join Date: Sep 2020
Posts: 6
Default

Hello I just purchased my first Motorhome with slides and when I was checking the coach out the slides would not go out or in. They found that the coach batteries were weak so had to wait until the were fully charged and then there was a solenoid on the outside panel that needed to get reset after that everything worked.
Draco is offline   Reply With Quote
Old 10-11-2020, 10:43 AM   #3
miked
New Member
 
Join Date: Dec 2019
Posts: 9
Default

check your hydraulic fluid
miked is offline   Reply With Quote
Old 10-11-2020, 11:28 AM   #4
Sd7316411
New Member
 
Join Date: Mar 2018
Posts: 3
Default

For ours, the drivers seat has to be moved fully forward. I also leave the engine running when moving them in or out.
Sd7316411 is offline   Reply With Quote
Old 10-11-2020, 12:28 PM   #5
bse12854
New Member
 
Join Date: Oct 2018
Posts: 10
Default

The breaker should be as you walk in should be on the floor on the sink side panel. That’s were mine is on a 2007 BT. The actual motor is a worm gear driven not hydraulic. Good Luck my bedroom slide went but I was able to rebuild the casing blew apart.
bse12854 is offline   Reply With Quote
Old 10-11-2020, 03:13 PM   #6
CAP
Member
 
Join Date: Oct 2006
Location: Long Island
Posts: 45
Default

It could also be the switch. Take the panel off and unplug the switch that works with the one that doesn't. It's just a plug and play switch. On one trip I had to leave my panel off and switch the switches until I could get a replacement. On mine also have to have the emergency brake on before any slide will move and I have three.
__________________
2006 BT Cruiser 5291
A Genealogy Research Vehicle
CAP is offline   Reply With Quote
Old 10-19-2020, 01:23 AM   #7
hossross
Member
 
Join Date: Jul 2020
Location: Detroit
Posts: 36
Default

I had to get some rubber seal lube and spray them, no problem sense. Mine was also a rack and pinion gear drive not hydralic
hossross is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:29 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×