Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-13-2022, 04:40 PM   #1
Tim 6316
New Member
 
Join Date: Jul 2019
Posts: 10
Default No Power to Slide

2006 Class C Conquest 6316. Also noticed no power to light in the compartment which has the slide motor. Side went out 2 inches, then stopped. I suspect it's a fuse, but can't find it. Main panel fuses are fine, fuses/breakers in battery compartment are fine. Even changed the slide switch. Must be a fuse somewhere. Any ideas ladies and gentlemen? FYI, its electric motor (I replaced in 2019), emerg brake is on, seat is forward, and engine is off.
Tim 6316 is offline   Reply With Quote
Old 11-14-2022, 09:02 AM   #2
Vinnie
New Member
 
Join Date: Apr 2021
Posts: 24
Default

Which chassis is your coach on?

On my coach the engine must be on to move slides. There are fuses under the hood, in the panel in front of the passenger seat and at the RV electrical panel.
__________________
Vinnie
2009 Endura 6341
Bulletproofed Engine (turned out not to be bulletproof)
Vinnie is offline   Reply With Quote
Old 11-14-2022, 01:19 PM   #3
pwerwagn
Member
 
pwerwagn's Avatar
 
Join Date: Jan 2021
Location: Bosque Farms, NM
Posts: 87
Default

My old 6316 (kodiak chassis) had some similar issues with the slide. I got tired of all the slide nannies, so I rewired my slide out to bypass everything. Power straight from the battery, thru a fuse, to the switch. Then a new larger power cable from the batt straight to the relay. It made the slide work much better on mine.
__________________
2009 Supernova 6372
Sold: 2005 6316 Ultra Super C
pwerwagn is offline   Reply With Quote
Old 11-20-2022, 05:52 PM   #4
THenne1713
Senior Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 604
Send a message via AIM to THenne1713 Send a message via Yahoo to THenne1713
Default

Many/most slides powered directly from Battery, with a 12vdc CIRCUIT BREAKER within 18" of battery. Check battery compartment, look for a tripped RESET. Good Luck. There are some powered by fuses from POWER CENTER, but do not think GS does much of that.
__________________
THenne1713
2000 Conquest LE 6266, Class-C on 99-E450SD, 6.8, 2v, V-10
THenne1713 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:16 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×