Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-20-2023, 01:04 PM   #1
Bobc
New Member
 
Join Date: Mar 2023
Location: Silioam Springs
Posts: 10
Default Newbie from Arkansas

Me and the wife just got our first Class A and 2 years from retirement. cant wait. its a 2003 Gulfstream sun Voyager 8368 Work Horse. Believe we got everything working now. Had to replace heater, convection oven and some other odds and ends. any help would be greatly appreciated.
Bobc is offline   Reply With Quote
Old 03-26-2023, 10:07 AM   #2
RY469
Senior Member
 
Join Date: Apr 2021
Posts: 279
Default

I just fixed jacks on a unit like yours. System is obsolete, so I repaired the controller myself (bad N-channel MOSFET causing left front jack to misbehave). Workhorse is a good GM chassis. What issues are you still having?
RY469 is offline   Reply With Quote
Old 03-27-2023, 05:25 AM   #3
Bobc
New Member
 
Join Date: Mar 2023
Location: Silioam Springs
Posts: 10
Default

My front left jack seems to fade from time to time? any clue there
Bobc is offline   Reply With Quote
Old 03-27-2023, 06:53 AM   #4
RY469
Senior Member
 
Join Date: Apr 2021
Posts: 279
Default

Quote:
Originally Posted by Bobc View Post
My front left jack seems to fade from time to time? any clue there
What do you mean by "fade" ?
RY469 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:28 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×