Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-18-2021, 09:49 PM   #1
tdsx2jcs
New Member
 
Join Date: Nov 2021
Posts: 1
Default 2021 Vintage Cruiser 23RSS - Water Heater

I can't get my water heater to warm!

I have gas operational, the tank is full, the bypasses are not on, the furnace and stove work, no fuses are tripped, the breakers are "On". Both Electric and Gas Heater switches are lit (no faults).

But my water heater will not ignite on gas or start via electric. Am i missing something? Is there an outside switch on the 2021 model, because the heater looks totally different than the 2020 model.

No youtube videos on the newest 2021 models yet that i can find...
tdsx2jcs is offline   Reply With Quote
Old 11-19-2021, 10:38 AM   #2
Chuck v
Senior Member
 
Join Date: Dec 2009
Posts: 769
Default

Most likely your water heater is an Atwood or a Suburban, so look at the ID tag for a model number of the heater itself -- then find a manual on-line. Some of these heaters have switches and valves right on the unit that you need to confirm are in the right position. Posting a picture here will help us help you...


Chuck
__________________
2007 Tour Master T40C
Acura MDX toad

"It takes a great deal of time to recover from any improvement..."
Chuck v is offline   Reply With Quote
Old 11-28-2021, 10:55 AM   #3
THenne1713
Senior Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 444
Send a message via AIM to THenne1713 Send a message via Yahoo to THenne1713
Default

If you have outside shower, check tht valves are closed; if open and off at handheld, that acts as bypass too, mixing cold w/ hot leaving tank.
__________________
THenne1713
2000 Conquest LE 6266, Class-C on 99-E450SD, 6.8, 2v, V-10
THenne1713 is offline   Reply With Quote
Old 11-28-2021, 10:58 AM   #4
THenne1713
Senior Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 444
Send a message via AIM to THenne1713 Send a message via Yahoo to THenne1713
Default

There is an outside hard to find switch on many units that shuts off 12v; turned off when winterized to prevent heating empty
__________________
THenne1713
2000 Conquest LE 6266, Class-C on 99-E450SD, 6.8, 2v, V-10
THenne1713 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:46 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×