Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-26-2021, 01:55 AM   #1
friendship8405
New Member
 
Join Date: Nov 2021
Location: Ashland
Posts: 1
Default generator not charging batteries

My generator is will not charge or operate 12v system??
friendship8405 is offline   Reply With Quote
Old 12-01-2021, 08:52 AM   #2
Zapper58
New Member
 
Zapper58's Avatar
 
Join Date: Aug 2019
Posts: 11
Default

Hello, you might check the generator circuit breakers at the generator. There should be at least 1. Might need to pull a cover to find it. Check the owners manual.
__________________
Jim Zapp
08 BTouring cruiser 5290
07 Ford cutaway chassi
Zapper58 is offline   Reply With Quote
Old 12-05-2021, 09:25 AM   #3
gwirth
New Member
 
Join Date: Nov 2011
Location: Henderson
Posts: 26
Default

If your 120 volt circuits are working, then it is probably your inverter. Your decisions will be fix yours or install a new one.
gwirth is offline   Reply With Quote
Old 12-05-2021, 09:35 AM   #4
THenne1713
Senior Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 495
Send a message via AIM to THenne1713 Send a message via Yahoo to THenne1713
Default

CONVERTER is the Charger. If you have 120vac at receptacles*, check Circuit Breaker for CONVerter in Breaker Panel?

If not tripped, there is a (pair** of 30a fuses, labeled REVERSE POLARITY) on POWER CENTER converter end of charge wire, and a 12vdc CIRCUIT BREAKER on battery end of same wire, (next to battery, with a RESET button on small end).

(* If no power to RECEPTACLES, check main breaker on GEN itself, usually right behind the Onboard START Switch); (**One = CONVERTER TO POWER CENTER Fuses, OTHER = FUSE PANEL to BATTERY.)
__________________
THenne1713
2000 Conquest LE 6266, Class-C on 99-E450SD, 6.8, 2v, V-10
THenne1713 is offline   Reply With Quote
Old 01-20-2022, 01:54 PM   #5
THenne1713
Senior Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 495
Send a message via AIM to THenne1713 Send a message via Yahoo to THenne1713
Default

The GEN Provides 120vac to the CONVERTER which supplies 12vdc to the POWER CENTER FUSES. You can check Converter output at both sides of the TWO 30a (main) fuses at Fuse Panel; (if battery was installed reversed polarity, it blows these fuses.) One= Between Fuse Panel and Converter; One= Between Fuse Panel/ Battery. You may have one/ both blown, or maybe other issues, (loose wires, GEN problems, etc.? There are also MAIN BREAKERS (one or two, depending on GEN size) on the GEN itself, (near/ behind the on-GEN START switch on most). Good Luck
__________________
THenne1713
2000 Conquest LE 6266, Class-C on 99-E450SD, 6.8, 2v, V-10
THenne1713 is offline   Reply With Quote
Reply

Tags
friendship 8405

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:56 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×