Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-17-2022, 05:31 PM   #1
tip
New Member
 
Join Date: Sep 2022
Posts: 4
Angry What causes an engine to just die?

I own a 96 Sun Voyager 460 w/Banks Powerpack..53,000mi. Just recently my motorhome started behaving strangely. I idle my motor to charge an interior back up battery attached to an inverter for no more than 30min. Its quieter and takes less time than running my gen for the same purpose (Im in the process of switching to solar). Recently while idleing my motor will just stop. No warning just stop. It used to start right back up but now its stubborn as hell. Im currently beside the road she wont start and I have no clue what to check. Recently replaced plugs, wires, cap and rotor. when she starts she has a smooth idle. when I try to drive she exhibits loss of power, backfiring, low acceleration. I admit to not being a great mechanic anybody have an idea where to start?

Thank You
Tip
tip is offline   Reply With Quote
Old 09-17-2022, 05:59 PM   #2
AppliedThinking
New Member
 
Join Date: Aug 2020
Posts: 21
Default

Did you change out the fuel relay and check the fuse. Mine is in the front engine compartment right of center. The fuel relay did the trick for me.
AppliedThinking is offline   Reply With Quote
Old 09-17-2022, 06:10 PM   #3
Life on the fishing pier
Member
 
Join Date: Jun 2022
Location: West Lafayette
Posts: 78
Default

I wonder how much heat is being generated under the doghouse during your recharge time. You may be overheating some electronics.
__________________
Do the common uncommonly good.
Life on the fishing pier is offline   Reply With Quote
Old 09-17-2022, 09:56 PM   #4
tip
New Member
 
Join Date: Sep 2022
Posts: 4
Default thank you for your replies.. keep em coming

As for the relay and fuse... I'm going out to check them now...

i cant think of anything that would cause a motor to just die.. 1 second shes idleing smooth no issues.. then she just stops no warning nothing once in a while she starts again but yesterday and today i wait for hours... got 1chance yesterday and she died in the street before i could turn her around.. i had to be pulled off the road.
tip is offline   Reply With Quote
Old 09-18-2022, 08:02 AM   #5
AppliedThinking
New Member
 
Join Date: Aug 2020
Posts: 21
Default

As others have suggested, you can swap out fuel relay with the horn relay. All the relays are the same in my model. Some folks even suggested jumpers to bypass the relay. I think it's easier just to carry a couple of extras and plug them in.


Hopefully your battery disconnect suite (chassis and coach) are in good order. I rebuilt mine to be on the safe side due to the age of the rig.
AppliedThinking is offline   Reply With Quote
Old 09-25-2022, 03:09 PM   #6
THenne1713
Senior Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 602
Send a message via AIM to THenne1713 Send a message via Yahoo to THenne1713
Default

CHECK FUEL PRESSURE, REPLACE FUEL PUMP CUBE RELAY ($10+/-), and hope it is not a pump issue. Many other possibilities, but this relay often overlooked. Had two other cars, replaced PUMP, then had to replace relay to cure.
__________________
THenne1713
2000 Conquest LE 6266, Class-C on 99-E450SD, 6.8, 2v, V-10
THenne1713 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:45 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×