Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-17-2022, 01:18 PM   #1
washetas
New Member
 
Join Date: Jan 2022
Posts: 26
Unhappy 7 point connector

Well here I go again.Purchased a used 2003 gulfstream Friendship G7 and everything I check into needs repair of some kind.My new issue is I have a 4 prong which works but my seven point has zilch(no power).Does anyone know if there is a fuse that needs to be checked and if so,where might it be? Any thoughts would be helpful and always appreciated.Peace to all and Happy Travels.(I hope to be able to join you all someday) Ughh!!
washetas is offline   Reply With Quote
Old 05-18-2022, 12:24 AM   #2
Bike Dr
Senior Member
 
Bike Dr's Avatar
 
Join Date: Jan 2022
Location: Chestertown
Posts: 164
Default

There are multiple fuses that operate the 7 pin connector. Running lights fuse for trailer, brake FUSES depending if you have a brake controller and turn signals all on different fuses. You need to see where the two leads tie in and see where the connection is lost if the 4 pin is working correctly and you are sure of it! If the two options are made together you may have a faulty combo plug. You will need a test light or multi meter to help.
Bike Dr is online now   Reply With Quote
Old 05-18-2022, 10:12 AM   #3
washetas
New Member
 
Join Date: Jan 2022
Posts: 26
Default

Thanks Bike DR,
Thanks for the quick response.Have found where they come in together.As you know ,most is covered with the tubing cover and hard to decipher.I will check all fuses.I ordered a seven point testor so as I can keep checking for light activity.Just doesnt make sense that the four prong is active and the seven not.Always frustrating.Appreciate you and thanks.Peace
washetas is offline   Reply With Quote
Old 05-18-2022, 04:01 PM   #4
Bike Dr
Senior Member
 
Bike Dr's Avatar
 
Join Date: Jan 2022
Location: Chestertown
Posts: 164
Default

Mine has separate fuses for the trailer hook up so keep in mind there could be multiple fuses..
Bike Dr is online now   Reply With Quote
Old 05-22-2022, 10:55 AM   #5
Dennis4809
Senior Member
 
Join Date: Apr 2013
Location: Graham
Posts: 201
Default

Pass side rear compartment. Small box marked Bussmann. Remove cover, check the fuses.
__________________
2006 Gulf Stream Friendship G7
350 Cat, Crusier Lift w/ Honda VTX
Blue Ox and 2019 Chevy Blazer RS AWD V6
Dennis4809 is offline   Reply With Quote
Old 05-23-2022, 01:47 PM   #6
Willyt
Member
 
Join Date: Sep 2018
Posts: 50
Default Seven pin

I would check related fuses of course and then start with tracing where the ground wire is, might just be rusted and not making contact anymore. Good luck !
Willyt is offline   Reply With Quote
Old 05-31-2022, 09:04 PM   #7
Bike Dr
Senior Member
 
Bike Dr's Avatar
 
Join Date: Jan 2022
Location: Chestertown
Posts: 164
Default

Hey washetas!! Any luck on the 7 pin? I hooked up our trailer for the car and bike and had the right turn signal out on the the trailer only! It was only a fuse in the rear panel of my coach. Glad it was simple but had me wondering if you were able to trace out the problem with yours..
Bike Dr is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:24 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×