RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-01-2020, 12:13 PM   #1
Bbreternitz
New Member
 
Join Date: Oct 2020
Posts: 1
Default Black tank flush

I have a 2011 canyon trail 5th wheel. The black tank flusher worked fine early in the season, now I get water leaking out under side of camper when flushing. I think it might be a faulty anti siphon valve, but I canít find it. Had a service tech look & he couldnít find it either. He looked behind shower valves, but not there. Any other suggestions on what could be leaking? Thanks in advance.
Brad
Bbreternitz is offline   Reply With Quote
Old 10-18-2020, 12:37 PM   #2
THenne1713
Senior Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 271
Send a message via AIM to THenne1713 Send a message via MSN to THenne1713 Send a message via Yahoo to THenne1713
Default

Anti-syphon, or hose connection leaking? Many are remote and connected by hose? Either way, follow the water. or apply AIR AND LISTEN/ TRACE?
__________________
THenne1713
99-Conquest Ltd-C 6266, E450SD, 6.8, 2v, V-10
THenne1713 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:48 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×