Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-08-2021, 01:56 PM   #1
Immtnhigh
New Member
 
Join Date: Jun 2021
Posts: 1
Default Electrical help/ideas

Hi!! Iím new to this forum. I have a 1994 GS Ultra 26í and have some electrical issues.

I put new chassis and house batteries in and after about 3 days they were drained. Iím traveling from Boerne, TX and had planned on heading for the high country in AZ to get in the cool forest areas and boondock most of the summer. Long story short, found an RV repair place and he put in a new solenoid that fixed that problem but the batteries were still draining too quickly.

I have a friend who is a whiz at this stuff and went to where he was working/staying north of Yuma, AZÖughÖHOT! He took one look at the mess of wires under the hood and got to work. 3 hours later, it looked brand new and clean and the batteries were looking good. Fired up the on-board generator to see if we could get some a/c going. It ran a few minutes then quit. Now I have no 110 at all. He tried everything he knew to do and said he thought weíd need to start pulling wall coverings and run wires. From doing this with horse trailers, I know thatís a major job and headache and especially in that heat. I told him no that Iíd head to the high country and try to figure it out. The MH is running ok, just need to figure out the 110.

My question is, where would I find the location of the house fuse panel? My manual is kind of generic and says itís on the DS near the floor. Not there. My friend tried and looked everywhere he thought to try and couldnít find it either.

Any ideas? Thoughts? Heelllpp! Iím staying for a few days at a friendís house in Phoenix so at least Iím in a/c and thatís wonderful. If I canít get this figured out in a couple of days, going to head into the high country and keep working on it.

Thanks! Iím not a total novice. Been traveling for 3 1/2 years in other rigs. Bought this last October and itís been a total mistake but Oh well, got to deal with it now. Thanks for any ideas, Linda and little dog, Belle.
Immtnhigh is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:34 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×