Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-18-2020, 08:32 PM   #1
FastEddie87
New Member
 
Join Date: Feb 2018
Posts: 17
Default Hot water heater

Hello to all my friends and fellow our viewers I'm having a small problem my pilot light continues to work and sometimes goes out which means the heaters not working any clues
FastEddie87 is offline   Reply With Quote
Old 09-19-2020, 05:04 PM   #2
Frnzkchar
New Member
 
Join Date: Sep 2019
Location: LEHIGHTON
Posts: 16
Send a message via AIM to Frnzkchar Send a message via Skype™ to Frnzkchar
Default

Old school Pipe cleaner
Frnzkchar is offline   Reply With Quote
Old 09-27-2020, 09:43 AM   #3
miked
New Member
 
Join Date: Dec 2019
Posts: 9
Default

take an air hose and blow everything out, most likely debris
miked is offline   Reply With Quote
Old 09-27-2020, 10:25 AM   #4
VaHappyCamper
New Member
 
Join Date: Mar 2019
Location: Christiansburg
Posts: 20
Default

As has been previously stated, the line could have something in them (bugs are famous for hiding in there), the thermocouple could be weakening or it could be as simple as the pilot flame needs to be increased slightly (I've encountered this problem previously).

I hope this helps.
VaHappyCamper is offline   Reply With Quote
Old 09-27-2020, 08:31 PM   #5
networkguy
New Member
 
Join Date: May 2020
Posts: 8
Default

Same thing in a pilot light in those "non-movable homes", spiders like sit flow and they put tiny webs everywhere.

If it is an older unit, the new ones light from a power on the COACH Power side. No pilot burning, they also can run on shore power reducing the use of LP gas
networkguy is offline   Reply With Quote
Old 09-30-2020, 05:00 PM   #6
FastEddie87
New Member
 
Join Date: Feb 2018
Posts: 17
Default

Thank you that's exactly what it was great community God bless everyone
FastEddie87 is offline   Reply With Quote
Old 10-07-2020, 09:59 AM   #7
FastEddie87
New Member
 
Join Date: Feb 2018
Posts: 17
Default Water Heater /Heat

I put this up a little while back and I got some answers but now I'm at another Park and when I went to turn the hot water on turn the power on and the little yellow light did not come on so I went and checked the gas was not all the way on I just had it filled up opened it up tried the heater cool air but when the heater came on the yellow light came on but no heat came out basically I don't think it's getting any propane where should I start please help it's a 2002 Gulfstream sun Voyager
FastEddie87 is offline   Reply With Quote
Old 10-07-2020, 12:02 PM   #8
VaHappyCamper
New Member
 
Join Date: Mar 2019
Location: Christiansburg
Posts: 20
Default

Quote:
Originally Posted by FastEddie87 View Post
I put this up a little while back and I got some answers but now I'm at another Park and when I went to turn the hot water on turn the power on and the little yellow light did not come on so I went and checked the gas was not all the way on I just had it filled up opened it up tried the heater cool air but when the heater came on the yellow light came on but no heat came out basically I don't think it's getting any propane where should I start please help it's a 2002 Gulfstream sun Voyager
If you just changed (recharged)the tank and everything was working right previously, I would suggest turning the tank off, unscrew the gas line from the tank, reconnect the line and SLOWLY reopen the gas valve on the tank. If you inadvertently turned it on too fast, there is a valve inside that will shut off the flow. There also may be some air in the line from the tank switch. The simple fix is to lite the stove to bleed the air out of the lines, then try the hot water heater again.

Hopefully this will work.
VaHappyCamper is offline   Reply With Quote
Old 10-22-2020, 08:23 PM   #9
FastEddie87
New Member
 
Join Date: Feb 2018
Posts: 17
Default Need Help

Hot 🔥 water pilot light will not light on it's own I went lit it saw is on then had wife turn on the water heater in Rig then I hear like strike light up but after 2-4 I see pilot light on gane ?
FastEddie87 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:20 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×