Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-14-2022, 07:16 AM   #1
Swiarda
New Member
 
Join Date: Dec 2022
Posts: 2
Default 2007 Crescendo Stop Engine Light

I’ve a (new to us) 2007 Crescendo 8390 CRW with the MBE 926 engine. Picked it up at the dealer, drove it home (about 50 miles or so) and parked it in my driveway to tackle the remodeling requests made by the CEO. Started it up the other day to be greeted by the “Check Engine” and “Stop Engine” lights. My limited research said this is most likely an issue of low coolant. The coach is sitting at a slight rearward angle, so I figured the coolant was not hitting the sensor correctly. I had a mechanic come by yesterday to look everything over; he said I have sufficient coolant. I ran the on-board engine diagnostics and no faults were reported. Mechanic thinks that I have a faulty oil pressure sensor (not the one that reports to the dash gauge) … are we on the right track?
Swiarda is offline   Reply With Quote
Old 05-30-2023, 02:56 PM   #2
Silversliver
New Member
 
Join Date: Feb 2022
Posts: 9
Default

Had this on my 2007 crescendo. I had let it sit long enough for the chassis batteries to get to a low voltage state. Came up with this indication. Charged the batteries and it cleared.
Silversliver is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:11 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×