Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-07-2009, 02:18 PM   #1
s79vette
Junior Member
 
Join Date: Jun 2005
Location: Twin Lake,Michigan
Posts: 18
Default dead battery??

Went out today in Glorious sunshine to start motors on rig. Got genny running and engine wouldn't turn a lick. No power to anything with ignition turned on. Checked batteries and all were good 13plus volts and no corrosion. Went back inside and played with headlite switch and just happened to push emergency lite button and got a chattering noise. Turned it off and on a few times until they worked and tried key and motor started.
May be a relay that wasn't closing properly that supplies voltage to ignition system and dash functions, don't know, but it finally started. Steve
__________________
2003 Gulfstream Ultra Supreme
2004 Liberty,BluOx,BB
https://mysite.verizon.net/res77g99/
s79vette is offline   Reply With Quote
Old 02-10-2009, 12:04 PM   #2
RayChez1
Senior Member
 
Join Date: Jun 2005
Posts: 1,219
Default

A few years ago I had a simular problem. I would start the engine and when I would start going it would stop. It done it about three times. To me it was like if somebody was shutting the ignition switch off. So I took the ignition switch off and noticed that the back side of the switch was kind of expanded out and was not making good contact. I got a piece of wire and wrapped it around the switch and tightened it up to bring the back cover into place and apparently that was the problem, because I have never had that happen again. And I was going to replace the switch, but since it has not given anymore problems I just left it as is. It has been now at least five years with no problems. So like they say, if it is not giving problems, leave it alone.
__________________
2002 Gulf Stream Scenic Cruiser
2018 Buick Envision Essence
Neway Freightliner chassis
Aventa II Blue Ox
RayChez1 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2015 259 BH Battery going Dead rickster58 Travel Trailers 5 04-29-2015 04:19 PM
dead battery skyking Class C 1 03-02-2011 07:23 PM
dead battery frank Class A 2 02-27-2010 11:12 AM
Chassis Battery Dead after 2 weeks; reason? jhan Class A 5 01-10-2009 04:22 PM
dead batteries juan Electrical 11 02-07-2007 12:51 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:12 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×