Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-10-2009, 08:22 PM   #1
jetliner
Junior Member
 
Join Date: Nov 2009
Location: Pennsylvania
Posts: 19
Default 99 Sun Voyager- Furnace

All,

I've been having problems with my furnance and it won't come on at all. At first, I thought it might be a pilot issue or a thermostat problem. Is is possible for the furnace not to come on if the house batteries are low or dead? I found out all the batteries need replacement. Your thoughts? Thanks in advance.
__________________
Gulfstream Sun Voyager
1999 Diesel Pusher M-8362
275 HP Cummins
jetliner is offline   Reply With Quote
Old 12-10-2009, 10:28 PM   #2
holmesaw
Senior Member
 
Join Date: Nov 2007
Location: Bullhead City
Posts: 119
Default

Oh Yes! Bad batteries = no heat.
__________________
2005 Sun Voyager, Safe-T-Steer
2009 Chevrolet Malibu, Blue Ox, SMI Duo,
Ohio Cardinal Gulfstreamers
FMCA Gulfstreamers International
Good Sam
holmesaw is offline   Reply With Quote
Old 12-11-2009, 05:15 AM   #3
jetliner
Junior Member
 
Join Date: Nov 2009
Location: Pennsylvania
Posts: 19
Default

Thanks Holmes. I really hope that fixes it because its been really frustrating not been able to warm up the rig.
__________________
Gulfstream Sun Voyager
1999 Diesel Pusher M-8362
275 HP Cummins
jetliner is offline   Reply With Quote
Old 12-11-2009, 12:54 PM   #4
tucson_sailors
Junior Member
 
Join Date: Oct 2009
Posts: 28
Default Easy way to check if the electronics are bad or its battery

Can you hook up to shore power or spin up the onboard genny? I'm in the process of troubleshooting my furnace, and I get the spin-up on the fan, but not getting ignition either. My house batteries are shot, but I hooked up to shore power and all of a sudden I got *something* which was a decided improvement.

I'm guessing from the year of your rig that you have a DSI (direct spark ignition) not a pilot light. Whats the make of your furnace? If you have the original paperwork it'll be on there, if not there may be a model number on the furnace if you have access to it via the basement area.

Glenn in Tucson
tucson_sailors is offline   Reply With Quote
Old 12-11-2009, 03:58 PM   #5
jetliner
Junior Member
 
Join Date: Nov 2009
Location: Pennsylvania
Posts: 19
Default

I haven't hooked it up to 50 amps as the coach was designed for, but the furnace did not come up when I hooked it up to my house line either. When I bought it, the dealer had it connected to 50 amps and it worked. The frustrating part is that it quit on me halfway home going through Wyoming at night when it was 0 degress out.

Right now, I don't get anything from the furnace. I replaced all 4 batteries today, and while that fixed some things, was not sufficient for the heat. I'm taking it in Monday and will report if you like what they find.
__________________
Gulfstream Sun Voyager
1999 Diesel Pusher M-8362
275 HP Cummins
jetliner is offline   Reply With Quote
Old 12-11-2009, 04:26 PM   #6
holmesaw
Senior Member
 
Join Date: Nov 2007
Location: Bullhead City
Posts: 119
Default

Did you check to see if the propane was turned on at the tank? Does the referigerator work on Propane?
__________________
2005 Sun Voyager, Safe-T-Steer
2009 Chevrolet Malibu, Blue Ox, SMI Duo,
Ohio Cardinal Gulfstreamers
FMCA Gulfstreamers International
Good Sam
holmesaw is offline   Reply With Quote
Old 12-11-2009, 09:35 PM   #7
jetliner
Junior Member
 
Join Date: Nov 2009
Location: Pennsylvania
Posts: 19
Default

Everything that runs on LP Gas runs well. I'm beginning to think the issues are electric related. I had an inverter installed and overloaded the thing and a few things are not working right. I think I will go back to square one on the inverter and hope the furnace will go back to normal. At least I'll suggest that to the shop on Monday.

It seems so odd because most SV owners haven't had issues with the heater, so lets hope its a simple fix.
__________________
Gulfstream Sun Voyager
1999 Diesel Pusher M-8362
275 HP Cummins
jetliner is offline   Reply With Quote
Old 12-12-2009, 03:46 PM   #8
RJ82much
Site Team
 
Join Date: May 2005
Posts: 572
Default

What do you mean by "hooked it up to the house line? A dogbone adaptor with 120volt adaptor plugged into the 50 amp plug?

Did anything elso work when plugged in? Lights? You could have some breakers tripped. If your batteries are dead, perhaps your main disconnects have opened. The furnace is 12volts, is it not?

You will have to get some kind of charge on the house batteries if they are dead. Perhaps run your engine for a while to charge that battery, then depress the dashboard "battery" switch, maybe called auxiliary, or who knows what. The engine alternator will rapidy apply charge to the house batteries. During that period with the batteries paralleled, try to see if the furnace will run.

Don't use the auxiliary switch if your engine is not running because you may end up with dead engine battery.

Again, I would check that circuit breakers are not tripped. Your dc convertor circuit breaker could be a culprit.
__________________
Bob

'05 Sun Voyager #8351
https://www.much2see.com/index.html
RJ82much is offline   Reply With Quote
Old 12-12-2009, 06:36 PM   #9
jetliner
Junior Member
 
Join Date: Nov 2009
Location: Pennsylvania
Posts: 19
Default

The house line is a regular 120V outlet that would normally put out 30 amps. The coach will take 30 amps, but need 50 to run things as designed and charge the batteries as well. When I plugged into my house, all the lights, AC, Fans, Refrigerator, etc worked.

The main breaker panel is right in front of the bed and I did a reset on the main breaker. Nothing was popped, but did the recycle to see if it works. The furnace should be 12V, but I just put new batteries and nothing to show for in the heating department.

Let me ask you, I have 2 switches on the door steps for the coach and chassis to use the batteries or store the coach. What you are talking about sounds something different in a Main Disconnect switch. How is it normally identified on a Gulfstream and where are they usually located? I'll check the converter breaker as well.
__________________
Gulfstream Sun Voyager
1999 Diesel Pusher M-8362
275 HP Cummins
jetliner is offline   Reply With Quote
Old 12-12-2009, 09:06 PM   #10
RJ82much
Site Team
 
Join Date: May 2005
Posts: 572
Default

Hi Jetliner,

One thing I've learned is that it seem as though no 2 RVs are ever identical, though the same functions are always there.

The main disconnects I referred to are the ones on the steps. Yes, they are on if you've got lights & fridge

You have installed & charged new house batteries, and all circuit breakers are on.... It doesn't sound like your coach electrical system. Maybe thermostat or furnace itself?

Front thermostat is switched to heat & temperature turned up higher than room? (In my coach, only the front thermostat controls the furnace). Because my furnace has been trouble-free for years, I've never seen it. You might want to look at yours, search for a fuse, a reset button, and most importantly, the manufacturer & model number. Manuals can then be located online.
__________________
Bob

'05 Sun Voyager #8351
https://www.much2see.com/index.html
RJ82much is offline   Reply With Quote
Old 12-14-2009, 07:34 PM   #11
jetliner
Junior Member
 
Join Date: Nov 2009
Location: Pennsylvania
Posts: 19
Default

RJ,

I found out today that I had a bad time relay for the furnace (whatever that is). So hopefully it will all be fixed by tomorrow. Thanks for all the tips.
__________________
Gulfstream Sun Voyager
1999 Diesel Pusher M-8362
275 HP Cummins
jetliner is offline   Reply With Quote
Old 12-14-2009, 10:50 PM   #12
RJ82much
Site Team
 
Join Date: May 2005
Posts: 572
Default

Let us know if that takes care of it... We all learn from this.
__________________
Bob

'05 Sun Voyager #8351
https://www.much2see.com/index.html
RJ82much is offline   Reply With Quote
Old 12-15-2009, 07:57 PM   #13
jetliner
Junior Member
 
Join Date: Nov 2009
Location: Pennsylvania
Posts: 19
Default

The time relay did it. It works fine. The thing cost me $85 including labor. Works like a charm and heated the coach rather quickly.
__________________
Gulfstream Sun Voyager
1999 Diesel Pusher M-8362
275 HP Cummins
jetliner is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Furnace 03heritagerider Class A 5 03-19-2016 08:11 PM
Furnace 03heritagerider Electrical 2 03-19-2016 09:41 AM
NO FURNACE NO AC RVTrucker FEMA Trailers 3 01-26-2014 05:44 PM
furnace Jim2012 FEMA Trailers 0 10-18-2012 12:31 PM
furnace ray and margaret 5th Wheels 1 03-17-2010 10:32 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:09 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×