Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-25-2020, 09:27 PM   #1
trudyw
New Member
 
Join Date: Apr 2020
Posts: 2
Question No power to slide & jacks

I have a 2008 Canyon Trail 5th wheel. I was extending the jacks and it just quit. Jacks & slide won't work. Have checked the fuses, breakers and fuses on the converter and they are all okay. Where else can I look for a fuse or switch?
trudyw is offline   Reply With Quote
Old 04-27-2020, 09:23 PM   #2
Colorado350
Senior Member
 
Colorado350's Avatar
 
Join Date: Oct 2019
Posts: 102
Default

How did you check the fuses? Do you have power at the switch? Any loose wires near the slide or jacks?
__________________
John
The sheep always complain about the Sheepdogs UNTIL the Wolves show up then they beg for help!
Colorado350 is offline   Reply With Quote
Old 04-27-2020, 11:06 PM   #3
trudyw
New Member
 
Join Date: Apr 2020
Posts: 2
Default

I finally figured it out. There was a very small reset button on one of the relays that had tripped.
trudyw is offline   Reply With Quote
Old 04-28-2020, 05:48 PM   #4
Colorado350
Senior Member
 
Colorado350's Avatar
 
Join Date: Oct 2019
Posts: 102
Default

I would experiment with everything to see WHY it tripped… The last thing you wanna do is go camping, get ready to leave and nothing works and you can’t figure out why. Glad you figured it out.
__________________
John
The sheep always complain about the Sheepdogs UNTIL the Wolves show up then they beg for help!
Colorado350 is offline   Reply With Quote
Old 05-04-2020, 07:23 AM   #5
UltraBama
New Member
 
Join Date: Nov 2019
Location: Midway
Posts: 2
Default

If it Trips again, backtrack, starting at batteries and fuse on firewall to fuse in hydraulic compartment, then to diverters & inverters. Then, check slide & Jack's the mechanism; ALL should be lubricated on a scheduled basis? Been there before, and always happens when you don't use them frequently enough, even in storage? Good luck & happy trails to ya
UltraBama is offline   Reply With Quote
Old 05-04-2020, 03:09 PM   #6
THenne1713
Senior Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 247
Send a message via AIM to THenne1713 Send a message via MSN to THenne1713 Send a message via Yahoo to THenne1713
Default

Quote:
Originally Posted by trudyw View Post
I have a 2008 Canyon Trail 5th wheel. I was extending the jacks and it just quit. Jacks & slide won't work. Have checked the fuses, breakers and fuses on the converter and they are all okay. Where else can I look for a fuse or switch?
Tripped mine twice w/ slides when solenoids stuck ON; replaced solenoids and issue cured.
__________________
THenne1713
99-Conquest Ltd-C 6266, E450SD, 6.8, 2v, V-10
THenne1713 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:59 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×