Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-18-2020, 06:33 PM   #1
backscrub224
New Member
 
Join Date: Oct 2018
Location: College Park
Posts: 2
Unhappy No DC current in coach

Well, I had power in the RV since I had it and then no power due to dead batteries. I discovered that I may have had a Power converter problem, so I changed it out the old one had been in since it was manufactured. Now I have one that monitors the power w/ float charging by Progressive Dynamics. After my install, I still have no DC power, only AC power when on Shore Power. I've tried looking for manual breaker to do a reset by pushing in the button, but can't find it. I also discovered that my fan on the Power Converter is not turning, but the light on the circuit board flashes in all modes correctly. Can someone please help me, and if you know of a good mobile RV mechanic that can help in Atlanta, GA. please let me know...


Thanks fellow Rvers
backscrub224 is offline   Reply With Quote
Old 06-18-2020, 10:33 PM   #2
Frutza
Senior Member
 
Frutza's Avatar
 
Join Date: Nov 2012
Posts: 281
Default

The switch for turning the coach on, by the door, is it on? Is it working? Can you hear the relay? with a test light, meter to sensitive, unplug from 110, your converter & test for 12 volt on the battery connection, if you have 12 volt there, go to the coach relay & check for 12 on both sides of the relay
__________________
Mike & Becky
2005 Crescendo 8356
Frutza is offline   Reply With Quote
Old 06-28-2020, 11:57 AM   #3
THenne1713
Senior Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 247
Send a message via AIM to THenne1713 Send a message via MSN to THenne1713 Send a message via Yahoo to THenne1713
Default

1) Sounds like DISCONNECT between CONVERTER AND FUSE PANEL, (NO Battery or CONVERTER power to the FUSES?) and common is a pair of (x2) Blown REVERSE POLARITY 30a FUSES, often on fuse board ABOVE row of others; if battery was installed backwards, will usually blow BOTH 30a fuses 2) CONVERTER COOLING FAN ONLY WORKS ON HEAT/ LOAD, so low load/ no load = No Fan Needed (MINE has never run since converting to LED Lights); 3) I have seen pics of (some) fuse boards w/ no RP fuses visible, wonder if they are mounted on BACK of fuse board and require board to be unmounted to see?
<< Well, I had power in the RV since I had it and then no power due to dead batteries. I discovered that I may have had a Power converter problem, so I changed it out the old one had been in since it was manufactured. Now I have one that monitors the power w/ float charging by Progressive Dynamics. After my install, I still have no DC power, only AC power when on Shore Power. I've tried looking for manual breaker to do a reset by pushing in the button, but can't find it. I also discovered that my fan on the Power Converter is not turning, but the light on the circuit board flashes in all modes correctly. Can someone please help me, and if you know of a good mobile RV mechanic that can help in Atlanta, GA. please let me know...>>
__________________
THenne1713
99-Conquest Ltd-C 6266, E450SD, 6.8, 2v, V-10
THenne1713 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:30 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×