Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-04-2022, 03:48 PM   #1
KPMullen
Member
 
Join Date: Dec 2020
Location: Sioux Falls (PMB)
Posts: 32
Default Both bedroom slides dead

Just pulled into my overnight stop on my way north... and neither bedroom slide (closet or bed) works. [They were fine when I buttoned up this morning.]

The auto fuses for the bed slide and slideout (#7 & #8 in the House 2 12v fuse panel) are both fine.

The 15A breaker for the bed base is not tripped.

And the two bedroom auto fuses in the DC distribution panel are fine as well.

Any thoughts as to what I'm overlooking?

2007 T-40C for reference.

Thanks,

Kevin
__________________
Kevin

2007 Tour Master T40-C
2012 Jeep Liberty Toad

Full-timer
KPMullen is offline   Reply With Quote
Old 05-15-2022, 09:22 AM   #2
zippyphd
New Member
 
Join Date: Jul 2016
Posts: 21
Default

Are your house batteries charged? Is your bed up?
zippyphd is offline   Reply With Quote
Old 05-15-2022, 09:58 AM   #3
KPMullen
Member
 
Join Date: Dec 2020
Location: Sioux Falls (PMB)
Posts: 32
Default Both bedroom slides dead

Yes & yes. (Bed had to be up in order to close slides.)

I did some more investigating and found a 30A mini-breaker (labeled 'Slide 2') in the rear electrical compartment was blown.

I put a jumper on it to operate the slides and found a replacement online.

Situation resolved.

Thanks,

Kevin
__________________
Kevin

2007 Tour Master T40-C
2012 Jeep Liberty Toad

Full-timer
KPMullen is offline   Reply With Quote
Old 05-15-2022, 02:47 PM   #4
lipmsp
New Member
 
Join Date: May 2018
Posts: 4
Default

Set your emergency brake
lipmsp is offline   Reply With Quote
Old 05-15-2022, 02:52 PM   #5
proost
Member
 
Join Date: Feb 2019
Location: Scottsdale (Full-time though)
Posts: 75
Default

Quote:
Originally Posted by KPMullen View Post
Yes & yes. (Bed had to be up in order to close slides.)

I did some more investigating and found a 30A mini-breaker (labeled 'Slide 2') in the rear electrical compartment was blown.

I put a jumper on it to operate the slides and found a replacement online.

Situation resolved.

Thanks,

Kevin
Great that you got it resolved. Enjoy the full-time life. We love it and I think we've seen ONE, just one other Tourmaster on the road since we started 2-1/2 years ago! Hope to see you out there!
Attached Images
File Type: jpg IMG_3675.jpg (285.0 KB, 2 views)
__________________
Phil R
2007 Tourmaster T40A
A Year to Volunteer
proost is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:05 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×