Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-13-2022, 03:38 PM   #1
Tank
New Member
 
Join Date: Jan 2022
Posts: 4
Default Check valve location

City water hookup is leaking water whenever I use the freshwater pump. I know there's a check valve but where is it located? I have a 2005 BT Cruiser model 5270 and learned that it's not the water pump causing the problem. I see where it comes in but it disappears under the wheel well box. Any advice is more than welcomed!!
Tank is offline   Reply With Quote
Old 11-13-2022, 10:08 PM   #2
NavyLCDR
Member
 
Join Date: Feb 2021
Posts: 95
Default

Quote:
Originally Posted by Tank View Post
City water hookup is leaking water whenever I use the freshwater pump. I know there's a check valve but where is it located? I have a 2005 BT Cruiser model 5270 and learned that it's not the water pump causing the problem. I see where it comes in but it disappears under the wheel well box. Any advice is more than welcomed!!
It is a disc built into the connection that goes through the wall. It's the white center piece under the screen:

Capture1a.jpg
NavyLCDR is offline   Reply With Quote
Old 11-13-2022, 10:10 PM   #3
NavyLCDR
Member
 
Join Date: Feb 2021
Posts: 95
Default

Lot's more info here:
https://www.loveyourrv.com/rv-city-w...ly-and-repair/
NavyLCDR is offline   Reply With Quote
Old 11-15-2022, 04:34 PM   #4
Tank
New Member
 
Join Date: Jan 2022
Posts: 4
Default

Thanks for getting back to me!!
Tank is offline   Reply With Quote
Old 11-20-2022, 03:41 PM   #5
THenne1713
Senior Member
 
Join Date: Aug 2017
Location: Memphis
Posts: 604
Send a message via AIM to THenne1713 Send a message via Yahoo to THenne1713
Default

If the SCREEN is installed concave/ facing in, the screen can press the valve and keep it open. I have read (some) flip screen to hold it open when winterizing to put in sanitize or antifreeze solutions?
__________________
THenne1713
2000 Conquest LE 6266, Class-C on 99-E450SD, 6.8, 2v, V-10
THenne1713 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:06 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×