Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-25-2024, 09:41 PM   #1
Newdrewconquest89
New Member
 
Join Date: Apr 2024
Posts: 1
Default New dress hello all with my 89 conquest

Hey all just got an 89 conquest and started tearing it down , any experience in layout and system updates that work well with existing wiring and any and all ideas opinions are all welcome ! The rv has 74k miles and drives real strong except when hits 65 sounds like exhaust starts flowing from under the engine, any ideas what causes this itís a specific spot on the throttle too and it didnít effect the engine speed pick up or anything just heard the sounds and wanted to know if this is something I need to attend to anyways Iím in Oregon and we did over the cascades twice already and it was better than my 09 Ö. Other than the noise ! Thanks all super excited to be a part of the community and I am very handy so if ever in. Red and close letís connect !!
Newdrewconquest89 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:59 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×