Gulf Stream Owners RV Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-10-2008, 05:49 PM   #1
Curt Krueger
Member
 
Join Date: Aug 2007
Location: Modesto
Posts: 50
Default Air Cleaner Gauge

Hi all,
We hve a 2005 Crescendo with the caterpillar C7 350 HP. I have had problems with the air cleaner on the unit since day one and was wondering if anybody else has the same experience.
The gauge that measures the air flow through the filter reads all the way to the top almost all the time. I change the filter more than neccesary so I know it is not that. I have removed the hose, both ends and tried moving air through it and all seems ok. I can reset this unit , drive a hundred miles and it is pegged at the top.
The air intake is about 5" and the hose from the air box is also 5" so no restrictions there. I wonder if I need to open the intake hose to a 7" coming from the box and then reduce it down to 5" as it enters the filter.

Anybody have any ideas?

Curt
__________________
2005 Crescendo triple, 2000 Blazer toad, Brake Buddy,DW,2 cats and lots of patience
Curt Krueger is offline   Reply With Quote
Old 06-10-2008, 10:09 PM   #2
rdlamb
Senior Member
 
Join Date: Jun 2007
Posts: 386
Default

Hi Curt:
Do you have a canister type of air filter? What make/brand did you use and when did you last change it?

I have a 400 Cummins, with a canister type of air filter. Just after we took possession of our coach, the indicator went to the red level. I wondered if the air filter could really go bad after only 4000 miles, but decided not to take any chances.

At the time, I was visiting my folks, on our family farm. We usually have our tractors, trucks, and heavy motor air filters cleaned at a local farm and ranch store.

When I took the air filter in, alas, no can clean a canister filter. But, they could test it. The filter was truly dirt laden.

So, I replaced it with a Baldwin. $125

One year later I replaced the filter again, just for preventative maintenance, with a NAPA, for $96. The NAPA didn't last 6 months before the indicator was in the red. Another Baldwin, and another full year without problems.

I just replaced the filter today, with another Baldwin.

So, long winded answer is, it may truly be plugged, and it may be the type of filter you are using. I can recommend a Baldwin.



__________________
Safe Travels
Rick
07 TM 40D;ISL 450 Cummins(upgraded). Very happy w/coach
Gnarly toad to scoot around.
Geocaching, hiking, fishing, National Parks, Civil War sites.
rdlamb is offline   Reply With Quote
Old 06-11-2008, 07:34 AM   #3
GStream40
Site Team
 
Join Date: Nov 2005
Posts: 911
Default

Rick,
Could it be that the Baldwin is not as fine a Micron filtration and is filtering out as much dirt as the NAPA filter ?

If so, more dirt is entering your engine for increased wear.

Just a thought, maybe you can find out what Micron each filter is.

Ron
GStream40 is offline   Reply With Quote
Old 06-11-2008, 08:46 AM   #4
rdlamb
Senior Member
 
Join Date: Jun 2007
Posts: 386
Default

Hi Ron:

I have a lot of trust in Baldwin, Fleetguard, Lubrifiner, Donaldson air filters. I brought up the issue because I read somewhere that NAPA sold the canister type filter that fits the TM, and there was a significant cost savings.

I tried the NAPA, and did not feel comfortable with the results. I think the NAPA plugged quickly. There was no increase in dust, or off road driving, or road construction, so the filter failed in my view.

Baldwin is what most of the semi(s), tractors, and heavy equipment on our farm use. We have used them for decades, with no problems.

Just bringing up the question, it could be the filter.



__________________
Safe Travels
Rick
07 TM 40D;ISL 450 Cummins(upgraded). Very happy w/coach
Gnarly toad to scoot around.
Geocaching, hiking, fishing, National Parks, Civil War sites.
rdlamb is offline   Reply With Quote
Old 06-11-2008, 03:54 PM   #5
Dapper Dan
New Member
 
Join Date: May 2008
Posts: 23
Send a message via ICQ to Dapper Dan Send a message via AIM to Dapper Dan Send a message via MSN to Dapper Dan Send a message via Yahoo to Dapper Dan
Default air cleaner

You might look at how your exhaust is pointed and if your rock guard is touching the ground. I think this causes all the material you run over to back draft toward the intake...
__________________
2005 GULF STREAM 8408
Dapper Dan is offline   Reply With Quote
Old 06-12-2008, 12:23 PM   #6
Curt Krueger
Member
 
Join Date: Aug 2007
Location: Modesto
Posts: 50
Default Air Cleaner Gauge

Thanks to all of you, this info is so valuable to me. It confirms to me that there are so many variations on these units.
I change this filter every year regardless of the miles. I use only filters from a Cat dealer here in Yuma, so there is no doubt about the quality of the product. I guess based on what I have heard from you just relax and don't worry about it. My mpg, temp and performance are in line with that of my peers, I monitor the engine functions with Silverleaf software so I know exactly what is happening.

Thank you all for the help.

Curt
__________________
2005 Crescendo triple, 2000 Blazer toad, Brake Buddy,DW,2 cats and lots of patience
Curt Krueger is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Erratic Gas Gauge redeye Class A 3 04-08-2015 04:57 PM
Temperature Gauge JIMNINA Class A 2 11-19-2013 06:46 PM
Voltage Gauge Jumping Neshaminy Electrical 0 10-18-2012 04:07 PM
Temperature gauge fluctuating chamberlain Class A 1 10-08-2007 06:26 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:31 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×